Results 1 to 9 of 9

Thread: nFinity Ultrabook and Ubuntu

  1. #1
    Dedicated Follower Pendragonuk's Avatar
    Join Date
    Feb 2009
    Posts
    922
    Thanks
    6
    Thanked 87 Times in 78 Posts

    Default nFinity Ultrabook and Ubuntu

    I picked up a new laptop last week, one of the new nFinity Ultrabook's LINK Right not I have it duel booting between Win7 64bit and Ubuntu 12.04LTS 64bit. Everything appears to work just fine right out of the box.

  2. The Following User Says Thank You to Pendragonuk For This Useful Post:

    icc97 (30-06-2012)

  3. #2
    Novatech Uber Techie
    Moderator
    Mike's Avatar
    Join Date
    Jan 2006
    Location
    Deep dark depths of southern England
    Posts
    1,885
    Thanks
    1
    Thanked 55 Times in 55 Posts

    Default

    Good to know regarding Ubuntu . I was toying with getting one of these but didn't want to use up a windows license for it.
    I'll have to look at saving some money up for one.
    Novatech Managed Services/Network Operations Centre

    ALL GLORY TO THE HYPNOTOAD

  4. #3
    Newcomer
    Join Date
    Aug 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Could you post that information on the Ubuntu-uk mailing list please? Thanks in advance.

  5. #4
    Newcomer
    Join Date
    Aug 2012
    Posts
    7
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Quote Originally Posted by Pendragonuk View Post
    I picked up a new laptop last week, one of the new nFinity Ultrabook's... Ubuntu 12.04LTS 64bit... Everything appears to work just fine right out of the box.
    @Pendragonuk - Which model is your nFinity? i have an nFinity 2637 i7 and can't get the touchpad to work with synaptiks / modules. What does your touchpad id as under 'dmesg | grep input' ??
    mine id's as 'ImExPS/2 Generic Explorer Mouse'

    see thread here

  6. #5
    Dedicated Follower Pendragonuk's Avatar
    Join Date
    Feb 2009
    Posts
    922
    Thanks
    6
    Thanked 87 Times in 78 Posts

    Default

    My nFinity is one of the first ones with a second gen (sandy) Intel i7 2637

    What might be worth looking at with your Ubuntu install is to make sure your running the 32bit version. Couple of things to remember with Ubuntu, they say that the 32 bit version is the recommended version for a reason... It's much more mature, 64 bit is still largely experimental. Much more is expected to fully work with the 32 bit version than the 64 bit one.

    The other big thing to be aware of is Linux doesn't suffer from Windows 32 bit memory issues. When Ubuntu is installed if it's on a computer with 4GB of RAM or more it will automatically install the PAE Kernel. This will allow it to access the RAM over the 32bit limit. There comes a point where you will want to run the 64bit version of Ubuntu, take the compatibility hit to gain complete access to the RAM that 64 bit will give you. However you would need to be running some very particular software to need it.

    For most regular users just running the 32bit version is the best way to go.

    As to why you are having so many issues with your nFinity when I'm not getting any issues at all I have no idea...

  7. #6
    Newcomer
    Join Date
    Aug 2012
    Posts
    7
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Found a fix / workaround
    note - this works with the 32bit version of Ubuntu 12.04, but not the 64bit version.

    edit /etc/default/grub
    change line GRUB_CMDLINE_LINUX=""
    to
    GRUB_CMDLINE_LINUX="i8042.noloop"
    run sudo update-grub
    reboot

    Touchpad options now show up in Ubuntu desktop settings.
    2 finger scrolling can now be selected and now working, and tap-to-click turned off.
    Last edited by vernona; 06-08-2012 at 08:05 PM.

  8. #7
    Dedicated Follower Pendragonuk's Avatar
    Join Date
    Feb 2009
    Posts
    922
    Thanks
    6
    Thanked 87 Times in 78 Posts

    Default

    Can you set it to disable when typing? So annoying to have your cursor jump while typing because your thumb brushes the pad.

  9. #8
    Newcomer
    Join Date
    Aug 2012
    Posts
    7
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Quote Originally Posted by Pendragonuk View Post
    Can you set it to disable when typing?
    Yes, all options in the ubuntu 'system settings - mouse and touchpad' work. Not tried to tweak anything beyond that yet.

  10. #9
    Newcomer
    Join Date
    Jan 2012
    Posts
    15
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Quote Originally Posted by vernona View Post
    Found a fix / workaround
    note - this works with the 32bit version of Ubuntu 12.04, but not the 64bit version.

    edit /etc/default/grub
    change line GRUB_CMDLINE_LINUX=""
    to
    GRUB_CMDLINE_LINUX="i8042.noloop"
    run sudo update-grub
    reboot

    Touchpad options now show up in Ubuntu desktop settings.
    2 finger scrolling can now be selected and now working, and tap-to-click turned off.
    So with that one mod, everything in http://www.novatech.co.uk/laptop/ran...nityn1401.html works out of the box ?
    Wireless, hibernate, bluetooth, HDMI etc ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •