BIOS update for laptop

I am trying to upgrade my laptop BIOS. The BIOS setup is very minimal, it doesn’t seem to include EZ Flash, so I tried to use AFUDOS.EXE, after booting FreeDOS from a USB stick. I tried 3 versions of AFUDOS, all downloaded from the AMI site today (AMIBIOS8, Aptio 4, Aptio V). None worked.

I also have the new BIOS ROM file (version 303). I first want to save a backup of my current BIOS. Because I can’t get that to work, I haven’t attempted to flash the new one. The command I tried to save the backup:
AFUDOS.EXE A15.207 /O
Error message:

46 - Error: Problem getting flash information

(I get the same error from the Windows GUI: AFUWINGUIx64.EXE)

Motherboard: Pegatron A15 version 1.0
Chipset: Ivy Bridge (revision 9)
CPU: i7 3610QM 2.3GHz

BIOS info:
AMI Aptio 2.13.1216
BIOS version: 207 (date: 02/05/2012)
VBIOS version: 2130.1I220910.01
EC version: 5300057F08
ME FW version: 8.0.4.1441

Order #5137879 - Placed on 07 Jul 2012 19:55
Novatech Custom nSpire 2760
Stock code : NNB-X02844
Labels on underside of laptop:

  • Serial No: 125PE2021720
  • Model: NNB-X02844 NNB-X02844 7316082-001

Many thanks.

(P.S. my reason for wanting to upgrade is that USB 3 devices, connected to USB 3 ports, show up as USB 2. Many people say a BIOS upgrade fixes it.)

Hi

Firstly please stop trying to flash the BIOS with what you have. AMI Tool is not the correct tool to use on those chassis and lucky for you cause the file you are trying to flash is not for your chassis. 303 is for A15A, you have A15YA, if you had managed to flash this it would have been the end of your unit.

I will check with supplier latest version for your unit as its been a while since I have seen one of these but in the meantime could you also let me know what OS you are running and what the Intel USB3 Driver version that is running as well as in most cases the issue is driver not BIOS.

OS: Windows 7 SP1, all Windows updates applied.
USB 3 driver is iusb3hub.sys, by Intel. Version 1.0.3.214, date 27/01/2012.

Thanks.

Can you install the following USB 3 driver and let me know if it helps with your issue

Driver installed. USB 3 now working. Thanks.

you’re welcome. Glad its working now.