Novatech Custom PC randomly not posting (VGA led on)

I’m having some issues with a PC that was received recently and I can’t seem to find a reason why, but this PC sometimes decides to just not post at all.

I’ve got an Asus X570 and here’s the LED reading I get:
CPU red then turns off
VGA white then stays on
Boot green then turns off

Only VGA LED stays on and the PC doesn’t post. No signal comes out the HDMI from the GPU or the MB.

I’ve tried checking the PCIE slot on the MB and unplugged replugged all the power cables of the GPU.

Still nothing.

Tried to check all the cables going to the PSU: clear.

Tried to remove the GPU, checked that there was no dirt or anything, made sure to put it back and push it firmly and completely into the MB.

All of this was done with the PC unplugged from power of course.

The PC then decided to finally post for some unknown reason.

And the next day, the PC decided not to post again.

I did the same thing again, checked cables etc. Tried to boot: no luck.

Then for some reason it suddenly posted.

I have no idea what’s happening XD if anyone knows what I should be doing, would be great.

Cheers o/

have you tried reseating the ram ?

Checked the RAM, it’s pushed in and lights up when I turn on the PC. I’ll try resetting it and see if it changes anything.