Ubuntu 19.04 on Novatech Tablet B28T

Disclaimer

Please be aware that this is in no way an endorsed installation method, nor will you receive any support beyond what is posted in this thread. This was done in my own time, through some trial and error, and general boredom. Novatech is a Microsoft Partnered Company and does not offer Ubuntu on a desktop level for customers. I cannot promise you this will not break things, and I can’t promise you this will give you a smooth experience. I would also warn, this is a little more advanced than a basic installation, so if you are not comfortable with Terminal, the BIOS of a machine, or Linux is still fairly new to you, I would give this a wide berth.

About

So, I’ve owned a Novatech touchscreen tablet (The B28T) for a while now. Used it for various things such as netflix watching, as a home automation hub and general on the go access to basic documents. I originally purchased it for the odd Java programming change needed for some projects when I was away from home. Now, however, it’s getting a bit long in the tooth, and I’m loathe to throw something away that I might find some use for. Since I now have a 3D Printer, the main goal of the project was to give me a nice Touchscreen interface, wifi connection, and Print server for said 3D printer. I won’t go that in depth, but just trying to get Ubuntu installed was a pain in the rear end for a number of reasons. Below, we’ll go over what you will need, along with why it’s such a pain in the rear end.

Items Required

  1. USB Stick 8gb in size
  2. Powered USB hub
  3. The following bootia32.efi file from github HERE
  4. Optional: Decent enough Wifi connection for updates during install + for additional drivers if required.

The Problem(s)

Most, if not all (haven’t had chance to look) of our Novatech tablets were supplied with the ability for a 64bit processor completely fine, but the EFI shell actually supplied on the unit is 32bit. With things moving pretty much entirely in the direction of 64bit, a 32bit EFI shell is a little bit of a struggle for Ubuntu, who have pretty much dropped any direct 32bit offering in recent years. This means, attempting to boot from a generic Ubuntu 19.04 installer USB is going to either have the USB not seen in the BIOS, or having you hunt through the file structure for the .efi file, only have it fail on boot due to it being 64bit.

The second, rather inconvenient issue, is that the USB port on the tablets don’t offer the best in terms of power output, so a powered USB hub for you to plug your USB stick into, is going to be a must!

Ubuntu Download + USB Set up

Creating a Ubuntu bootable USB stick is a fairly simple process, so we’re going to go through it on Windows as that’s my main machine.

You’ll first want to download the available ISO from the Ubuntu Website. I’m using 19.04 which is not their latest Long Term Support offering, however the same should work fine for 18.04 - it’s just not something I’ve personally tested.

Once you have the ISO downloaded, you’re going to need to need a tool like Rufus to pop that ISO onto a USB stick and then make that USB bootable.

Once this is done, we still need to do one VERY important change to the USB stick, remember that bootia32.efi we downloaded earlier? We need to put this in a specific folder on the USB stick. This will be: “EFI\BOOT” you will already see x64 versions, just pop this one in amongst them. This is the file that helps us get around the 32bit EFI shell!

Booting from USB

Fantastic, we have everything we need to get Ubuntu installed… now comes the interesting part, actually doing it. We first need to Boot from this USB we created. REMEMBER, you need to have your USB connected to a powered USB hub, which is then itself connected to the Tablet.

One the Tablet, that’s as simple as Powering the unit off, then Powering the system on, while holding the VOLUME DOWN + CAMERA button at the same time. This will get you to the following screen (excuse the reflections!):

Once you’re in here you will need to head boot manager and you should see something labelled along the lines of “EFI USB Device” much like the below image:

When you click this option, GRUB will give you a few choices. you MUST boot from “Try Ubuntu without installing”. This is extremely important, as we might need some information from this area before finishing up.

Installing Ubuntu

Well done! If all has gone well we are finally at the correct stage to install Ubuntu, and we’re at a basic “LIVE” Desktop of what Ubuntu will look like after installation. Now is the perfect time to make sure everything is working, keyboard, mouse, Wifi, speakers. I didn’t have any issues on the B28T tablet and Ubuntu 19.04, but your experience may change. Should you find things wrong here, I would advise giving up and not installing any further, because if those critical things aren’t working here, you’re only going to dig a bigger hole if you continue.

All you need to do is hit the install Ubuntu Icon like the below and follow it through.

install

It is likely you already have Windows installed on the Tablet, I have absolutely no idea what dual booting will do, or how GRUB will handle this, so I advise against it. When you get to the part of the installation that detects an OS, you should pick: “Erase Disk and install Ubuntu”. This will WIPE EVERYTHING currently on the Tablet. Once you hit this, there is no going back.

You may get an error telling you that grub efi ia32 has failed installation. If so, it is extremely important that you do the following below.

Before Rebooting

Once you’re all done with the installation Ubuntu will require you to reboot. This is the point where we say, not today. There are two things that might happen if you reboot right now. You might reboot and be completely fine and have the system boot into Ubuntu without issues. More likely, you will reboot and have Ubuntu yell at you because it can’t boot correctly.

With my installation of 19.04 it rebooted completely fine, however, this might not be the case on say 18.04 and below and the below is going to tell you how to fix this.

Remember that bootia32.efi file? That allowed us to boot up and install Ubuntu, but Ubuntu might not have been smart enough to use it for GRUB in the future. Which means when it tries to boot fresh, it will try and boot from a 64 efi Grub package and not the 32 that we want. This is something we can get around but it is going to take some information before we reboot the system out of this “LIVE USB” view.

You will need to open up Terminal. You can click “Show applications” in the bottom left, and in the Search bar, type terminal. Open this.

Once opened, run the following command:

sudo gparted

This is where things get a little complicated, we first of all need to find the drive that Ubuntu is installed on, if you look in the top right, you will find a list of devices connected. One will be your USB, the other your Internal Drive, we need the internal drive. From the picture below, you can see mine is: “/dev/mmcblk1” you need to write this down! it is very important:

Next you will need to find the partition that Ubuntu is installed onto, you need to see the “File System” list on that drive, for a file system listed as ext4. Much like the picture below, you can see mine is listed on partition “/dev/mmcblk1p2” this is also very important and something you need to write down:

Finally Rebooting

Now you can go ahead and reboot. You can remove the USB, but keep it handy just in case you’re unlucky and we need to fix GRUB. Now, if you’re like my installation of 19.04 you should boot up perfectly fine and you’re done!

If you’re unlucky

If you’re unlucky and it doesn’t boot and you get an error (this always happens for units which have the “grub efi 32” package installation error). Then we need to fix it. We need to pop back in the USB stick, and boot from it much like we did before by heading into the BIOS and then Boot Manager.

HOWEVER, once we get to the part that asks us to Try Ubuntu without installing we need to hit the “C” key on our keyboard, you will then get the below screen:

On this screen we need to enter a few commands, to trick the system into booting from our already installed Ubuntu, rather than the USB. To do that, we run the following commands without quotes:

linux /casper/vmlinuz.efi root=/dev/<partition>

replace with the previous information, for me that was “mmcblk1p2”

Then run

linux /casper/initrd.lz

Then run

boot

Ubuntu should start booting from your internal drive at this point and you can breathe a sigh of relief that it worked.

Fixing everything

Now that you’re booted up into your normal Ubuntu installation, we need to stop that from ever happening again. To do that we have to edit in the inbuilt GRUB from picking the correct place.

First, open up Terminal much like before, and lets update everything by running the following command:

sudo apt-get update

(it will ask for your password you set up during installation)

This just makes sure all of your system is update, remember it will need an internet connection for this!

Once done, we can go ahead and install the correct version of GRUB we need with the following command:

sudo apt-get install grub-efi-ia32-bin

We then need to run the following commands to make sure it installed and configures itself correctly, we use the following substituting with your Disk, mine for example was “mmcblk1”

sudo grub-install /dev/<Disk>

Then run

sudo grub-update

Moment of truth

From this point, you can unplug your USB stick and reboot normally and Ubuntu should come up without any issues. If this worked, thank goodness. You’re all done.

The End

As you can see, it’s not a simple process, but once you’re done you’re done. It means I can use it as a half decent print server for my 3D printer. As mentioned to begin with however, this is as much information as I can offer you. This was all done off my own knowledge and understanding of Linux. This is not something Novatech as a whole offer support for at all. If you ring us up with issues on this, there is nothing we can do. Thanks for reading, and I hope it helped out someone at least!

3 Likes