Ubuntu on Novatech Elite N1773

I’ve installed Ubuntu 16.04.3 on a Novatech Elite N1773 as the sole OS. Initially it would hang at the final stage where a reboot was solicited. From research here and elsewhere I surmised the nVidia card might be the problem so I set nomodeset as a boot option. Then I escaped the reboot prompt and launched Unity. From here I ran:

sudo apt-get update;
sudo apt-get full-upgrade;

The graphics card is showing as:

Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)

sudo apt-get install nvidia-390

lsmod shows nouveau drivers before and nvidia after. I’ve also tried nvidia-current. Is there a particular version of drivers that might work? Should I use a different windows manager or distribution?

Hey Leydar,

You’ve mentioned the system hanging, just to confirm the system is hanging after the initial installation of the Nvidia Drivers when it asks you to reboot?

First, I can’t remember the BIOS of that laptop directly; but head in and make sure you’ve turned off secure boot and anything else like that.

Right now, I’d suggest a full fresh install; so you know you’re starting from nothing, just in case the driver has just decided to mess up along the way.

I’d also go back to basics on the driver, don’t go to the current and instead try and install the first 10 series driver released properly for Ubuntu: “sudo apt-get install nvidia-367”

Reboot the system and see what you get. Also once you have rebooted and get chance to head into a terminal run: “watch -n0 nvidia-smi” just to see if the installation of the Drivers did go through (you should get a whole bunch of readouts in relation to the GPU).

Fully failing that, I don’t see why it would make a difference, but try 17.10 just to see as a last resort. (Personally I hate Unity so advise against it)

Cheers,

  • JASL

The system would hang after full Ubuntu 16.04 install. Not on Nvidia driver install.

UEFI/secure boot, fast boot is disabled.

I’ve reinstalled quite a number of times at this point.

Ah ha! This is the bit of information I was looking for. I had mistakenly thought the 384 drivers were the first to support the 1070. Reverting to 367 seems to have done the trick. At least on Ubuntu 17.10 that is.

I had tried 17.10. The nouveau drivers work much better but the nvidia drivers cause the screen to flash. Ultimately the downgrade to nvidia-367 worked a treat. Thank you for the suggestion.

Glad to hear you got it all up and running :slight_smile: