Usb devices not showing in explorer

In the last week or so I’ve been plugging in usb devices and they haven’t been showing up in explorer.

I think its since a major w10 update.

My phone, kindle fire and external usb hard drive now no longer show up and they were fine until recently.

I tried a different socket.
The kindle make a noise as though it knows its been connected (that might just be power though.)
My wireless usb mouse still works ok.
I tried shutting down, removing power and battery, holding down the power switch for 40 secs and then starting everything back up but devices still dont show. I tried this yesterday with my external hard drive and it did work but its gone again today.

After some googling i have unchecked the fast startup option that disables USBs and in device manager I have gone to USB controllers/usb root hub/properties/power management and unchecked the ‘allow computer to turn off device etc’ option and then did a full restart.

Still no joy.

Getting very frustrated. Please help!

Can you provide more detail on the system hardware spec please or if it is one of our systems what the model number is.

Where do I find the model number coops?

This will depend on the age of the system, however it will either be on the Rear of the system on a white sticker or on the side of the system if its a recent PC Tower. If its a laptop it will always be on the bottom of the unit.

Thanks:
model code: NNB-B97
part code: NNB-X07073
S/N: 7428829-01

Hold your horses. The one thing I didn’t try was another cable - and it was the cable.

What it doesn’t explain is the problem I had the other day but lets draw a line under this for now and if I get another problem I’ll post again.
Thanks for your help.

OK - it has happened again. The dodgy cable was a red herring and just affected my kindles. A new cable fixed that.

The original problem has reoccurred with the same usb external hard drive as before. I plug it and nothing happens (as if it hasn’t been plugged in). When I check in device manager under usb attached scsi (uas) mass storage device. I get the comment ‘Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)’

It’s a usb 3 toshiba 2.5" hard drive.

What cured it was a shut down, battery and power pull and holding in the power switch for 40 secs. On power back up it works again.

I can’t do all that every time I plug it in!

Is there a more permanent cure?

update - I just did the reset procedure and it didn’t work. I also tried a usb memory stick - a sandisk cruser and that didn’t appear either.