Windows 7 Clock time keeps going out of sync

Hi guys,

I have been having an issue with my windows time, it keeps going out of sync. My system is as follows:

Maximus impact 6 mobo
i7 4770k 3.5ghz (stock)
16GB ram
GTX 970
500GB samsung evo ssd
1TB storage drive
Windows 7 Ultimate 64 bit (payed for and registered).

I have tried:
ensuring time zone is correct
setting it to sync with internet time, on multiple different time servers
changing my cmos battery

It will just lose hours randomly, and when I turn it off and turn it on again in the morning, it will almost always have the time from last night still. If I go onto the internet time tab of the date/time menu and hit change settings>update now it will hold the correct time for say, an hour or two, before just falling behind again.

Im really out of ideas here, and Novatech forums have been great in the past helping me


Hello willsor, and welcome to the forums.

Is it only the Windows clock that seems to losing time or is the BIOS showing the same behaviour?

It would be worth trying to reset the Windows Time service to default to see if this helps,

1.Open a elevated Command Prompt.

2.Type net stop w32time and then press ENTER:

3.Type w32tm /unregister and then press ENTER:

4.Type w32tm /register and then press ENTER:

5.Type net start w32time and then press ENTER:

1 Like

Thanks for the reply Sebastion,

I tried that, and it doesnt seem to work. The BIOS is losing time as well, I turned it on this morning and it was again showing about half middnight which is when I turned it off last night…


Sorry to hear you’re still having issues

If the BIOS clock is also losing time then this tends to point more towards a mainboard (CMOS/BIOS/Battery) issue than anything Windows or software related.

Try doing a full reset on the BIOS by removing the mains cable, removing the CMOS battery from the board and then press and hold the power button for about 10 - 15 secs.

Firmly replace the battery and ensure it is seated correctly. ( it might also be worth, if you have one, checking the CMOS battery with multi-meter as its not unheard of these to be on the low side of 3v, especially if they have been sat about for sometime in distributors warehouses etc.) and power up the PC.

On POST you should get an error message asking you to go into the BIOS and load your default settings, which will include setting your BIOS clock again :frowning:

Save and exit the BIOS and see if the issue still persists, if it does it might be worth flashing your BIOS the latest version if you don’t already have it.



Hi Seb,
I have tried the battery remove/ hold button, to no avail, I will try to update the BIOS, but the asus website seems to be a bit messed up and I cant access the support page for my mobo


If your still having issues getting to the download page, willsor try the link below


Hi Seb,

Apologies for the very long delay. I finally installed the new motherboard version, and I was monitoring it for a couple of days. Unfortunately the problem is still at large, every time I turn it off, in the morning it says the time is the same as when I turned it off

HI Willsor,

Unfortunately it would seem that you have just about covered all the bases when it comes to this issue.
If you have reset/updated the BIOS and replaced the CMOS battery but the BIOS clock is still stopping when the unit is powered off, then it looks like an issue with the mainboard itself.

If it is still under warranty the give our tech support guys a call on 02392 322 500 opt 3 with your order details or alternatively ASUS directly (if outside the first year, as this usually has a quicker turnaround time) and arrange an RMA for the board to be looked at.


1 Like

Thanks for the help Seb,

Sounds like an RMA would be the best bet,

thanks for your help